Due to a GitHub token format change some SDMs may fail to clone private repositories
Incident Report for Atomist
Resolved
We have updated the underlying SDM code to work with Github's new token format. Customers experiencing authentication failures in their SDMs should follow the update instructions at https://github.com/atomist/sdm-pack-github-token/tree/main#usage.

Customers on latest 2.x versions of SDM libraries are asked to upgrade to SDM 2.1.4.
Posted Apr 01, 2021 - 12:51 UTC
Identified
Github made a change in the last few hours to their token format. Previously their app tokens were in the form of v1.token, they are now issued in the form of ghs_token. Atomist SDMs that work with private repos on github.com have a switch in the code to determine what type the token is. This is currently broken resulting in authentication errors.

We're working to release a new version of the SDM libraries that handle this new token format.
Posted Apr 01, 2021 - 09:20 UTC
This incident affected: Cloud Services.